jira.uhub.biz problems

Incident Report for Uhub

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 12:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2026 - 12:12 UTC

Identified

We've identified the possible cause and working on steps to fix. Jira may be available for some users and locations already.
Posted Jul 20, 2026 - 12:07 UTC

Investigating

We are currently investigating reports of problems with access to jira.uhub.biz. The team is working on this as highest priority.
Posted Jul 20, 2026 - 11:55 UTC
This incident affected: Uhub Jira and Service Management.