Uhub Jira Peformance Issue

Incident Report for Uhub

Resolved

This incident has been resolved.
Posted May 14, 2025 - 13:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 12:33 UTC

Identified

We aware aware of a problem with Uhub Jira causing the site to be unresponsive. The team is investigating.
Posted May 14, 2025 - 12:10 UTC
This incident affected: Uhub Jira and Service Management.