My Uhub unavailable
Incident Report for Uhub
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 22:14 UTC
Monitoring
We have restarted some services and My Uhub is back online
Posted Dec 18, 2023 - 07:37 UTC
Investigating
We are investigating an outage on My Uhub (https://my.uhub.biz)
Posted Dec 18, 2023 - 06:54 UTC
This incident affected: My Uhub.