Authentication Service Unavailable
Incident Report for Uhub
Resolved
This incident has been resolved
Posted Aug 01, 2019 - 16:24 UTC
Investigating
We are looking into login problems with Uhub for some users. Thank you for your patience.
Posted Aug 01, 2019 - 15:26 UTC
This incident affected: Uhub Authentication Services.