Uhub Jira Performance / Outage

Incident Report for Uhub

Resolved

This incident is resolved and Uhub Jira is fully operational again.
Posted May 30, 2025 - 20:38 UTC

Update

The team is still working to restore Jira service. Please continue to follow this incident for updates.
Posted May 30, 2025 - 20:18 UTC

Update

We are continuing to investigate this issue.
Posted May 30, 2025 - 18:47 UTC

Investigating

We aware of a problem with Uhub Jira causing the site to be unresponsive. The team is investigating.
Posted May 30, 2025 - 18:20 UTC
This incident affected: Uhub Jira and Service Management.