Authentication Services Degraded
Incident Report for Uhub
Resolved
This incident has been resolved.
Posted Aug 02, 2019 - 16:43 UTC
Investigating
We're currently aware of a problem with authentication services, which might affect access to Uhub.

Some users may experience problems or delays with login to Uhub applications. Contact the team via support@uhub.biz if you need assistance.
Posted Aug 02, 2019 - 05:05 UTC
This incident affected: Uhub Authentication Services.