Unexpected Email Shift
Incident Report for Uhub
Resolved
The vendor has pushed through a fix to resolve this issue. All impacted users should be restored to their previous email address.
Posted Aug 23, 2019 - 17:05 UTC
Identified
The Uhub team have identified a small subset of users whose email addresses/usernames may have been incorrectly changed in the infrastructure that Uhub relies on in the last 12 hours.

Users may not be able to login correctly using their usual username/password and some functionality like boards/filters that reference specific users may not function as expected.

Impacted users should notify IBM immediately @ https://wppit.service-now.com
Posted Aug 23, 2019 - 13:56 UTC