my.uhub.biz outage
Incident Report for Uhub
Resolved
my.uhub.biz is back online
Posted Nov 13, 2023 - 22:45 UTC
Identified
We are currently doing some critical maintenance on my.uhub.biz and it will be unavailable for ~ 30 minutes.
Posted Nov 13, 2023 - 22:41 UTC
This incident affected: My Uhub.