Jira Unavailable
Incident Report for Uhub
Postmortem

Jira was unresponsive during this time as it had numerous open connections to Crowd (the Uhub application that allows authentication requests to Active Directory) and Crowd had high CPU on both application nodes. Thread and heap dumps for Crowd were sent to Atlassian Premier Support for analysis which indicated that there were slow running SQL queries running to process Active Directory nested groups.

Both Crowd application nodes were restarted, releasing the stuck threads and Jira then returned to its functional state.

The Uhub team continue to work with Premier Support to understand what specific queries by Crowd triggered the issue and once identified, what we’re able to do to minimize the chance of re-occurrence.

Posted Apr 25, 2019 - 17:06 UTC

Resolved
This incident has been resolved
Posted Apr 18, 2019 - 16:21 UTC
Monitoring
We have restarted the nodes and are monitoring
Posted Apr 18, 2019 - 15:45 UTC
Investigating
We are currently investigating an interruption in Jira
Posted Apr 18, 2019 - 15:33 UTC
This incident affected: Uhub Jira and Service Management.