Authentication services degraded
Incident Report for Uhub
Resolved
This incident has been resolved.
Posted May 22, 2019 - 11:33 UTC
Monitoring
Authentication services are fully operational again. The team is monitoring.
Posted May 22, 2019 - 08:07 UTC
Investigating
We're currently aware of a problem with authentication services, which might affect access to Uhub.

Some users may experience problems or delays with login to Uhub applications. Contact the team via support@uhub.biz if you need assistance.
Posted May 22, 2019 - 07:53 UTC
This incident affected: Uhub Authentication Services.