Authentication Services Unavailable
Incident Report for Uhub
Resolved
Authentication services have been restored
Posted Oct 17, 2018 - 17:10 UTC
Investigating
We are currently investigating authentication services issues.
Posted Oct 17, 2018 - 16:43 UTC
This incident affected: Uhub Authentication Services.