Confluence Not Responding
Incident Report for Uhub
Resolved
This incident has been resolved
Posted Oct 16, 2018 - 15:10 UTC
Investigating
We are currently investigating Confluence not responding.
Posted Oct 16, 2018 - 14:55 UTC
This incident affected: Uhub Confluence.