LATAM Authentication Issues
Incident Report for Uhub
Resolved
Authentication services are fully operational again.
Posted Nov 08, 2018 - 18:06 UTC
Investigating
We are aware of intermittent authentication problems affecting some users in the LATAM region.

We have an incident open with our IT provider and will provide updates here on the progress.
Posted Nov 06, 2018 - 17:39 UTC
This incident affected: Uhub Authentication Services.